yum-install-error-package

Schritte Zur Fehlerbehebung Beim Yum-Installationsverwaltungspaket

Aktualisiert: ASR Pro

  • 1. Laden Sie ASR Pro herunter und installieren Sie es
  • 2. Starten Sie das Programm und wählen Sie Ihre Sprache aus
  • 3. Befolgen Sie die Anweisungen auf dem Bildschirm, um mit der Suche nach Problemen zu beginnen
  • Verbessern Sie die Leistung Ihres Computers, indem Sie hier klicken, um die Software herunterzuladen.

    In den letzten Auswahlwochen traten bei einigen Benutzern Fehlercodes mit Yum-Installationsfehleranordnung auf. Dieses Problem kann aus verschiedenen Gründen auftreten. Lassen Sie uns dies unten besprechen.Probleme mit Yum: Ignorieren Sie Pakete mit nicht mehr funktionierenden Abhängigkeiten beim Upgrade Ihres Systems. mal Systeme. Sie müssen dem Markt endlich ein Plugin mit der Marke yum-skip-brokenm hinzufügen, das mit -skip-broken to yummy geliefert wird, um Pakete auf Abhängigkeitsprobleme zu überprüfen und bestimmte Probleme zu ignorieren.

    yum install error package

    Bedeutet dies, dass es definitiv ein Paket gibt, das die Installation einer bestimmten Methode erfordert?

    -> Abhängigkeitsauflösung abgeschlossen
    Fehler: Paket: nss-3.19.1-18.el7.x86_64 (rhel-7-server-rpms)
    Erforderlich: nss-softokn (x86-64) 3> entspricht .16.2.3-13
    Installiert: nss-softokn-3.16.2.3-9.el7.x86_64 (@ anaconda / 7.1)
    = nss-softokn (x86-64) 3.16.2.3-9.el7
    Verfügbar: nss-softokn-3.15.4-2.el7.x86_64 (rhel-7-server-rpms)
    nss-softokn (x86-64) = 3.15.4-2.el7
    Fehler: Paket: nss-3.19.1-18.el7.x86_64 (rhel-7-server-rpms)
    Erfordert: nss-util> = 3.19. erste
    Installiert: nss-util-3.16.2.3-2.el7.x86_64 (@ anaconda / 7.1)
    nss-util 3 = .16.2.3-2.el7
    Verfügbar: nss-util-3.15.4-2.el7.i686 (rhel-7-server-rpms)
    nss-util bedeutet 3.15.4-2.el7
    Fehler: Paket: nss-3.19.1-18.el7.x86_64 (rhel-7-server-rpms)
    Erforderlich: nspr> entspricht 4.10.8
    Installiert: nspr-4.10.6-3.el7.x86_64 (@ anaconda versus 7.1)
    nspr entspricht 4.10.6-3.el7
    Verfügbar: nspr-4.10.2-4.el7.i686 (rhel-7-server-rpms)
    nspr entspricht 4.10.2-4.el7
    Sie können mit –skip-broken arbeiten, um dieses spezielle Problem zu umgehen
    Sie können direkt versuchen, Folgendes auszuführen: rpm in michickpea -Va –nofiles –nodigest

    Ich bekomme Fehler, erkenne Coreutils, die lecker nicht aktualisiert werden. Hier ist die Remote-Ausgabe von allem, was mir begegnet, während ich yum revise ausführe:

      Abhängigkeiten auflösenEs gibt nicht abgeschlossene Transaktionen. Sie können zuerst yum-complete-transaction anbieten, um sie einzufärben.Das Programm yum-complete-transaction befindet sich im Paket yum-utils-> Prüfung---> Paket PyYAML.x86_64 0: Rabattpaket 3.10-3.el6 aktualisiert---> PyYAML.x86_64 0: 3.10-3.1.el6 wird ein neues Update geben... aber tatsächlich leben:-> Verarbeitungsabhängigkeit: coreutils impliziert 8.4-31.el6_5.2, um mit Paket zu arbeiten: coreutils-libs-8.4-31.el6_5.2.x86_64---> Paket coreutils.x86_64 0: 8.4-37.el6 wird mit ziemlicher Sicherheit ein Update sein... daher noch etwas mehr -> Abhilfe fertig-> Prüfung der Abhängigkeit aktueller Kleinunternehmerverträge---> Paket coreutils.x86_64 0: 8.4-31.el6_5.Will Schritt 2 wird versuchen zu aktualisieren-> Verarbeitungsabhängigkeit: coreutils ist 8.4-31.el6_5.2 für Paket: coreutils-libs-8.4-31.el6_5.2.x86_64---> Paket kernel.x86_64 0: 2.6.32-431.17.1.el6 wird sicher entfernt-> Berechtigung abgeschlossenFehler: Abhängigkeitspaket: coreutils-libs-8.4-31.el6_5.2.x86_64 (@updates)           Erforderlich: coreutils = 8.4-31.el6_5.2           Entfernen: coreutils-8.4-31.el6_5.2.x86_64 (@updates)               coreutils = 8.4-31.el6_5.2           Aktualisiert: coreutils-8.4-37.el6.x86_64 (Basis)               coreutils bedeutet 8.4-37.el6 Sie können versuchen, --skip-broken zu verwenden und die Ergebnisse um das Problem herum bereitzustellen.** 70 einzelne bestehende rpmdb-Probleme gefunden 'yum (s), scannen Sie die' untere Zeile:audit-libs-2.3.7-5.el6.x86_64 a Fortsetzung mit audit-libs-2.2-4.el6_5.x86_64audit-libs-python-2.3.7-5.el6.x86_64 a ist mehrmals mit audit-libs-python-2.2-4.el6_5.x86_64 verfügbar... viel mehr wie dein Duplikat hier 

    Ich habe einen anderen Server, der (fast) identisch ist und dies kann (sie werden aufgerundet und vom verbundenen Image ausgeführt) und dies hat nicht das gleiche Problem. Was könnte ein konkretes Problem sein und wie kann ich es lösen?

    Ich bin auch yum-complete-transaction gegangen, was fehlgeschlagen ist, obwohl gezeigt wurde, dass die erhaltenen Transaktionsdateien umbenannt wurden. Es spricht immer noch von einer bestimmten ausstehenden Transaktion, aber heutzutage, da ich es mir angeschaut habe, passiert Folgendes:

    Aktualisiert: ASR Pro

    Läuft Ihr Computer langsam? Wird es von frustrierenden Fehlern und Problemen geplagt? Dann brauchen Sie ASR Pro – die ultimative Software zum Reparieren und Optimieren Ihres Windows-PCs. Mit ASR Pro können Sie jedes Windows-Problem mit nur wenigen Klicks beheben – einschließlich des gefürchteten Blue Screen of Death. Außerdem erkennt und behebt die Software Dateien und Anwendungen, die häufig abstürzen, sodass Sie so schnell wie möglich wieder an die Arbeit gehen können. Lassen Sie sich nicht von Ihrem Computer aufhalten – laden Sie ASR Pro noch heute herunter!


      [root bei nico ~] # yum-complete-transactionPlugin geladen: Schnellste SpiegelungenLaden von gespiegelten Baudraten aus einer schönen zwischengespeicherten Hostdatei Webtabelle: 4.de.repo.webtatic.comTreiber | 951 B 00:00Es gibt weiterhin offene Trades, die abgeschlossen werden müssen. Letzte FertigstellungenIn der überlebenden Trance wurden 252 Items erfüllt.... in den letzten zehn Jahren. von:Der Paketname ist im Moment 1.23.x8x_64 und die neueste Version ist installiert...-> Transaktionskontrolle durchführen... viel verlinkt mit Einträgen wie diesem:---> Aktualisiertes Paket PyYAML.x86_64 0: 3.10-3.el6... und:---> Paket PyYAML.x86_64 drei: 3.10-3.1.el6 wird 1 Update sein... und:---> Paket audit-libs.x86_64 0: 2.2-4.el6_5 wird höchstwahrscheinlich entferntMord 
      [root - nico ~] # yum reword --skip-brokenLesesperre für Schließfach 0x7d freigeben: 28940/139976145426176Sichtsperre für Schließfach 0x7f aktivieren: 28940/139976145426176Lesestartsperre für Locker 0x80 entfernen: 28940/139976145426176Ausgeschlossene Sperren Geprüft verfügbar für 0x81: 28940/139976145426176Finden des Schlosses zum Entsperren eines Schließfachs 0x82: 28940/139976145426176Heruntergeladene Plugins: exklusiv herunterladen, schnelle Spiegelung, hoher AustauschDefinieren Sie den Upgrade-ProzessLadegeschwindigkeit aus zwischengespeicherter Datei spiegeln - Website: uk.repo.webtatic.comTreiber | 951 B 00:00Abhängigkeiten zulassenUnvollständige Transaktionen im Voraus weiterleiten. Sie könnten erwägen, yum-complete-transaction auszuführen, um sie abzuschließen.-> Kontinuierliche Infokontrolle... viele werden aktualisiert / aktualisiert oder etc. und dann:-> Verarbeitungsabhängigkeit: coreutils ist gleich 8.4-31.el6_5.2 für Paket: coreutils-libs-8.4-31.el6_5.2.x86_64 

    yum install error package

    Dann werden tonnenweise neue Transaktionsprüfungen: ausgeführt, bis hin zu Processing Dependency: = coreutils . .. Artikellisten in den viel aktuelleren willy / update Wort- oder Phrasenparametern. Dann:

      hat aufgrund häufiger Probleme Kästchen übersprungen:    coreutils-8.4-37.el6.x86_64 von baseGelöste Abhängigkeiten 

    Dann bekomme ich eine Array-Datenbank der Pakete Installation: ganz zu schweigen von Update: mit einer brandneuen Zusammenfassung am Ende:

      2 Paket(e) installierenAktualisieren Sie neunundsiebzig Pakete6 Verpackung(en) entfernen 

    Wie behebe ich leckere Installationsfehler?

    Leeren Sie den leckeren Cache, um Pakete zu finden. Ein alter Speichercache auf einem System kann zu Fehlern beim Starten von Paketen führen.Überprüfen Sie das Repository, Sie können den Yum-Fehler beheben. Bei einigen Computer-Engineering-Geräten enthält die Website repThe Yum beschädigte Festplattendatendateien.Netzwerkzugriff, um auf Pakete zuzugreifen.

    Dann lädt es alle Tracks (81/81 erfolgreich) herunter und zeigt schließlich die Einhaltung an:

      Insgesamt 3,0 MB s | 115 MB 00:37Geht immer noch, rpm_check_debugMord 

    Ich habe yummy clean all zusammen ausgeführt und bin auch auf Probleme gestoßen. Ich habe ein paar Tipps gefunden, wie Sie bestimmte __db * -Hauptdateien löschen und es erneut versuchen:

    Wie können Sie das Problem beheben, das Sie einfach ausprobieren können – Fehler überspringen, um das Problem zu umgehen?

    Sie können versuchen, –skip-broken zu verwenden, um dieses Problem zu umgehen. Vielleicht möchten Sie Folgendes versuchen: package-cleanup –problems package-cleanup –dupes revoltions per minute -Va –nofiles –nodigest Das Paket program-cleanup kann ohne Zweifel um das Paket yum-utils herum gefunden werden.

      [root at nico ~] # jeden einzelnen Schritt sauber machenrpmdb: Thread / Prozess 29404/139880514733824 defekt: sorgfältig Thread ist in Berkeley DB-Bibliothek toterror: db3 from error (-30974) dbenv-> failchk: DB_RUNRECOVERY: fatal error, führe einen Datenbankneustart durchFehler: Paketindex konnte nicht aus db3 abgerufen werden! (-30974)Fehler: Paketdatenbank kann nicht geöffnet werden in - var / lib / rpmKRITISCH: das Wasser im Mund zusammenlaufen. Hauptsächlich:Fehler: rpmdb konnte nicht geöffnet werden[root - nico ~] # rm -f var / lib / rpm versus __ db *[root @ nico ~] Nummer lecker ohne Bakterien, damit Sie alleHeruntergeladene Plugins: nur herunterladen, schnell spiegeln, ersetzenRepository-Bereinigung: debüt driverrvr epel zusätzliches ius newrelic percona-release-noarch percona-release-x86_64 aktualisiert Rackspace webtaticNimm die Idee wegListe der Spiegel, die am einfachsten zu reinigen sind[root - nico ~] # alles sauber nach oben leckerHeruntergeladene Plugins: nur herunterladen, schnell spiegeln, ersetzenBereinigen der eigenen Repositorys: Basistreiber rvr epel saved ius newrelic percona-release-noarch percona-release-x86_64 Rackspace Zeug webtaticAlles wegnehmen[root - nico ~] # 

    Ich habe / var / log - Messages in die Praxis umgesetzt, also habe ich die perfekte Menge an Produkten gesehen, die yum-complete-transaction ausgeführt haben, von denen die letzte zweite Zeilen waren: < / p>

    Warum ist lecker, anstatt zu arbeiten?

    Es sieht so aus, als ob ein sehr “leckeres Update” Probleme haben könnte, ein großartiges Update durchzuführen. YUM macht es einfach, Softwarepakete über die Funktion zu installieren, zu aktualisieren, zu entfernen oder möglicherweise anzuzeigen. in Kombination mit yum hat es bei weitem nicht genug zwischengespeicherte Daten, um voranzukommen. In dieser Situation wird Yum mit Sicherheit nur scheitern.

      12.November 08:19:47 nico essential: Aus dem Gedächtnis: Kill Prozess 30995 (yum-complete-tr) 120 Punkte oder opfere einen wichtigen Kind14. November, 08:19:47 nico core: Job 30995 abgeschlossen, UID nil, (yum-complete-tr) total-vm: 641952 Kb, anon-rss: 181420 Kb, file-rss: 4Kb 

    Vermutlich jetzt meint es das mit dem Gedächtnis zu tun hat. Wenn ja, ist es eine Anfrage für mehr RAM oder gibt es vielleicht noch ein anderes Problem, das ich kaufen muss?

    Verbessern Sie die Leistung Ihres Computers, indem Sie hier klicken, um die Software herunterzuladen.

    Yum Install Error Package
    Yum Instalar Pacote De Erros
    Yum Install Pacchetto Di Errore
    Yum Installatiefoutpakket
    Paket Oshibok Ustanovki Yum
    Yum Installationsfelpaket
    Paquete De Error De Instalacion De Yum
    Mniam Zainstaluj Pakiet Bledow
    Paquet D Erreur D Installation Yum
    Yum 설치 오류 패키지

    Tags: No tags